Functional Test Plugin 2.0.M2 released

by Marc Palmer in


I released Functional Test plugin 2.0.M2 today. This is just the same as the 2.0.M1 release but without the false requirement for Grails 2. This is 2.0 milestoning is work-in-progress on reviving Functional Test plugin. Specifically it is now safe to use with Grails 1.3.x and 2.x without it resetting some of your project files.

The new 2.0 release has support for API testing without using a simulated browser, and is upgraded to the latest HtmlUnit library for simulated browser testing. There's a bunch of other refinements in there, but it is still very fluid.

If you like being at the bleeding edge or just need to get your old tests working with newer Grails releases give it a try and let me know if you have any trouble.

I'll try to put together some docs soon.